CVE-2006-1855

NameCVE-2006-1855
Descriptionchoose_new_parent in Linux kernel before 2.6.11.12 includes certain debugging code, which allows local users to cause a denial of service (panic) by causing certain circumstances involving termination of a parent process.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1184-2
NVD severitylow (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fai-kernelssourcesarge1.9.1sarge4lowDSA-1184-2
kernel-source-2.6.8sourcesarge2.6.8-16sarge5lowDSA-1184-2
linux-2.6source(unstable)2.6.12-1low

Notes

probably fixed before, but this is the oldest linux-2.6 in the changelog

Search for package or bug name: Reporting problems