CVE-2006-1945

NameCVE-2006-1945
DescriptionCross-site scripting (XSS) vulnerability in awstats.pl in AWStats 6.5 and earlier allows remote attackers to inject arbitrary web script or HTML via the config parameter. NOTE: this might be the same core issue as CVE-2005-2732.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1075-1
NVD severitylow
Debian Bugs364443, 365910

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
awstats (PTS)stretch7.6+dfsg-1+deb9u1fixed
stretch (security)7.6+dfsg-1+deb9u2fixed
buster7.6+dfsg-2+deb10u1fixed
bookworm, sid, bullseye7.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
awstatssourcesarge6.4-1sarge3DSA-1075-1365910
awstatssource(unstable)6.5-2medium364443

Notes

this might be the same core issue as CVE-2005-2732

Search for package or bug name: Reporting problems