CVE-2006-2016

NameCVE-2006-2016
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in phpLDAPadmin 0.9.8 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) dn parameter in (a) compare_form.php, (b) copy_form.php, (c) rename_form.php, (d) template_engine.php, and (e) delete_form.php; (2) scope parameter in (f) search.php; and (3) Container DN, (4) Machine Name, and (5) UID Number fields in (g) template_engine.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1057-1
NVD severitylow (attack range: remote)
Debian Bugs365313, 365314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpldapadmin (PTS)wheezy1.2.2-5fixed
wheezy (security)1.2.2-5+deb7u1fixed
jessie1.2.2-5.2fixed
buster, sid1.2.2-6.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
egroupwaresource(unstable)1.2-104.dfsg-1low365314
phpldapadminsource(unstable)0.9.8.3-1low365313
phpldapadminsourcesarge0.9.5-3sarge3lowDSA-1057-1

Notes

egroupware 1.2-1.dfsg-1 dropped phpldapadmin

Search for package or bug name: Reporting problems