CVE-2006-2082

NameCVE-2006-2082
DescriptionDirectory traversal vulnerability in Quake 3 engine, as used in products including Quake3 Arena, Return to Castle Wolfenstein, Wolfenstein: Enemy Territory, and Star Trek Voyager: Elite Force, when the sv_allowdownload cvar is enabled, allows remote attackers to read arbitrary files from the server via ".." sequences in a .pk3 file request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs660831

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ioquake3 (PTS)stretch (security), stretch1.36+u20161101+dfsg1-2+deb9u1fixed
buster1.36+u20181222.e5da13f~dfsg-2fixed
bullseye, sid1.36+u20200930.e7a7a2b~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ioquake3source(unstable)1.36+svn1788j-1
tremuloussourcesqueeze1.1.0-7~squeeze1
tremuloussource(unstable)1.1.0-6660831

Search for package or bug name: Reporting problems