CVE-2006-2083

NameCVE-2006-2083
DescriptionInteger overflow in the receive_xattr function in the extended attributes patch (xattr.c) for rsync before 2.6.8 might allow attackers to execute arbitrary code via crafted extended attributes that trigger a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs365614

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rsync (PTS)stretch3.1.2-1+deb9u2fixed
stretch (security)3.1.2-1+deb9u1fixed
buster3.1.3-6fixed
bullseye3.2.3-4+deb11u1fixed
bookworm, sid3.2.3-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rsyncsourcewoody(not affected)
rsyncsourcesarge(not affected)
rsyncsource(unstable)2.6.8-1high365614

Notes

[sarge] - rsync <not-affected> (xattr patch appeared in 2.6.7)
[woody] - rsync <not-affected> (xattr patch appeared in 2.6.7)

Search for package or bug name: Reporting problems