CVE-2006-2148

NameCVE-2006-2148
DescriptionMultiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1052-1
NVD severityhigh (attack range: remote)
Debian Bugs365680

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cgiircsource(unstable)0.5.9-1medium365680
cgiircsourcesarge0.5.4-6sarge1medium365680

Search for package or bug name: Reporting problems