DescriptionPostgreSQL 8.1.x before 8.1.4, 8.0.x before 8.0.8, 7.4.x before 7.4.13, 7.3.x before 7.3.15, and earlier versions allows context-dependent attackers to bypass SQL injection protection methods in applications that use multibyte encodings that allow the "\" (backslash) byte 0x5c to be the trailing byte of a multibyte character, such as SJIS, BIG5, GBK, GB18030, and UHC, which cannot be handled correctly by a client that does not understand multibyte encodings, aka a second variant of "Encoding-Based SQL Injection." NOTE: it could be argued that this is a class of issue related to interaction errors between the client and PostgreSQL, but a CVE has been assigned since PostgreSQL is treating this as a preventative measure against this class of problem.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs368645

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pygresql (PTS)buster1:5.0.6-2fixed
sid, trixie1:6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pygresqlsourcesarge(not affected)


[sarge] - pygresql <not-affected> (Already includes proper quoting)
Beginning with version 7.5.4, postgresql is a transition
package which does not contain actual code. That's why
it's marked as fixed here. (Previous versions are vulnerable.)
The following packages needed to adapted to cope with the new system:
psycopg 1.1.21-5 (bug #369230)
python-pgsql 2.4.0-8 (bug #369250)
pygresql 1:3.8-1.1 (bug #369239)
dovecot 1.0.beta8-3 (bug #369359)
postfix 2.2.10-2 (bug #369349)

Search for package or bug name: Reporting problems