CVE-2006-2458

NameCVE-2006-2458
DescriptionMultiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1081-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libextractor (PTS)jessie1:1.3-2+deb8u1fixed
jessie (security)1:1.3-2+deb8u3fixed
stretch1:1.3-4+deb9u1fixed
stretch (security)1:1.3-4+deb9u2fixed
sid1:1.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libextractorsource(unstable)0.5.14-1medium
libextractorsourcesarge0.4.2-2sarge5mediumDSA-1081-1

Search for package or bug name: Reporting problems