CVE-2006-2489

NameCVE-2006-2489
DescriptionInteger overflow in CGI scripts in Nagios 1.x before 1.4.1 and 2.x before 2.3.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a content length (Content-Length) HTTP header. NOTE: this is a different vulnerability than CVE-2006-2162.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1072-1
NVD severityhigh (attack range: remote)
Debian Bugs366682, 366683, 366803, 368193, 368199
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nagiossource(unstable)2:1.4-1high366682, 366803, 368193
nagiossourcesarge2:1.3-cvs.20050402-2.sarge.2highDSA-1072-1
nagios2source(unstable)2.3-1high366683, 368199

Search for package or bug name: Reporting problems