CVE-2006-2906

NameCVE-2006-2906
DescriptionThe LZW decoding in the gdImageCreateFromGifPtr function in the Thomas Boutell graphics draw (GD) library (aka libgd) 2.0.33 allows remote attackers to cause a denial of service (CPU consumption) via malformed GIF data that causes an infinite loop.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1117
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs372912
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)squeeze2.0.36~rc1~dfsg-5fixed
squeeze (lts)2.0.36~rc1~dfsg-5+deb6u1fixed
wheezy2.0.36~rc1~dfsg-6.1fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u1fixed
jessie, sid2.1.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.0.33-5low372912
libgd2sourcesarge2.0.33-1.1sarge1mediumDSA-1117
tetex-binsource(unstable)(not affected)

Notes

- tetex-bin <not-affected> (Links dynamically, see #382506)

Search for package or bug name: Reporting problems