CVE-2006-2937

NameCVE-2006-2937
DescriptionOpenSSL 0.9.7 before 0.9.7l and 0.9.8 before 0.9.8d allows remote attackers to cause a denial of service (infinite loop and memory consumption) via malformed ASN.1 structures that trigger an improperly handled error condition.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1185-2
NVD severityhigh (attack range: remote)
Debian Bugs389940
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)squeeze (security), squeeze0.9.8o-4squeeze14fixed
squeeze (lts)0.9.8o-4squeeze20fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u16fixed
jessie1.0.1k-1fixed
sid1.0.1k-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)0.9.8c-2high389940
opensslsourcesarge0.9.7e-3sarge4highDSA-1185-2
openssl096source(unstable)(not affected)
openssl097source(unstable)0.9.7k-2high

Search for package or bug name: Reporting problems