CVE-2006-2940

NameCVE-2006-2940
DescriptionOpenSSL 0.9.7 before 0.9.7l, 0.9.8 before 0.9.8d, and earlier versions allows attackers to cause a denial of service (CPU consumption) via parasitic public keys with large (1) "public exponent" or (2) "public modulus" values in X.509 certificates that require extra time to process when using RSA signature verification.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1185-2, DSA-1195-1
NVD severityhigh (attack range: remote)
Debian Bugs389940
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)squeeze, squeeze (security)0.9.8o-4squeeze14fixed
squeeze (lts)0.9.8o-4squeeze21fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u17fixed
jessie1.0.1k-3fixed
jessie (security)1.0.1k-3+deb8u1fixed
stretch, sid1.0.2d-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)0.9.8c-2high389940
opensslsourcesarge0.9.7e-3sarge4highDSA-1185-2
openssl096source(unstable)(unfixed)high
openssl096sourcesarge0.9.6m-1sarge4highDSA-1195-1
openssl097source(unstable)0.9.7k-2high

Search for package or bug name: Reporting problems