Descriptionparse-packet.c in GnuPG (gpg) 1.4.3 and 1.9.20, and earlier versions, allows remote attackers to cause a denial of service (gpg crash) and possibly overwrite memory via a message packet with a large length (long user ID string), which could lead to an integer overflow, as demonstrated using the --no-armor option.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1107, DSA-1115
NVD severitymedium (attack range: remote)
Debian Bugs375052, 375053, 375473
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg (PTS)squeeze, squeeze (security)1.4.10-4+squeeze4fixed
squeeze (lts)1.4.10-4+squeeze7fixed
wheezy (security)1.4.12-7+deb7u7fixed
stretch, sid1.4.19-2fixed
gnupg2 (PTS)squeeze, squeeze (security)2.0.14-2+squeeze2fixed
squeeze (lts)2.0.14-2+squeeze3fixed
wheezy, wheezy (security)2.0.19-2+deb7u2fixed
jessie, stretch, sid2.0.26-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupgsource(unstable)1.4.3-2low375052, 375473

Search for package or bug name: Reporting problems