CVE-2006-3125

NameCVE-2006-3125
DescriptionArray index error in tetrinet.c in gtetrinet 0.7.8 and earlier allows remote attackers to execute arbitrary code via a packet specifying a negative number of players, which is used as an array index.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1163
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gtetrinet (PTS)wheezy, buster, sid, jessie, stretch0.7.11-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gtetrinetsource(unstable)0.7.10-1high
gtetrinetsourcesarge0.7.8-1sarge2highDSA-1163

Search for package or bug name: Reporting problems