CVE-2006-3324

NameCVE-2006-3324
DescriptionThe Automatic Downloading option in the id3 Quake 3 Engine and the Icculus Quake 3 Engine (ioquake3) before revision 804 allows remote attackers to overwrite arbitrary files in the quake3 directory (fs_homepath cvar) via a long string of filenames, as contained in the neededpaks buffer.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severitymedium (attack range: remote)
Debian Bugs660832
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ioquake3 (PTS)wheezy1.36+svn2287-1fixed
jessie1.36+u20140802+gca9eebb-2fixed
stretch, sid1.36+u20150710+dfsg1-1fixed
tremulous (PTS)squeeze/contrib1.1.0-8~squeeze1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ioquake3source(unstable)1.36+svn1788j-1medium
tremuloussource(unstable)1.1.0-6medium660832
tremuloussourcesqueeze1.1.0-7~squeeze1medium

Search for package or bug name: Reporting problems