CVE-2006-3404

NameCVE-2006-3404
DescriptionBuffer overflow in the xcf_load_vector function in app/xcf/xcf-load.c for gimp before 2.2.12 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via an XCF file with a large num_axes value in the VECTORS property.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1116
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs377049
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)squeeze (security), squeeze2.6.10-1+squeeze4fixed
wheezy, wheezy (security)2.8.2-2+deb7u1fixed
jessie, sid2.8.14-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gimpsource(unstable)2.2.11-3.1medium377049
gimpsourcesarge2.2.6-1sarge1mediumDSA-1116

Search for package or bug name: Reporting problems