CVE-2006-3460

NameCVE-2006-3460
DescriptionHeap-based buffer overflow in the JPEG decoder in the TIFF library (libtiff) before 3.8.2 allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via an encoded JPEG stream that is longer than the scan line size (TiffScanLineSize).
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1137-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)squeeze (security), squeeze3.9.4-5+squeeze10fixed
squeeze (lts)3.9.4-5+squeeze11fixed
wheezy, wheezy (security)4.0.2-6+deb7u3fixed
jessie, sid4.0.3-12.1fixed
tiff3 (PTS)wheezy3.9.6-11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)3.8.2-6high
tiffsourcesarge3.7.2-7highDSA-1137-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (fixed prior to initial upload)

Search for package or bug name: Reporting problems