CVE-2006-3462

NameCVE-2006-3462
DescriptionHeap-based buffer overflow in the NeXT RLE decoder in the TIFF library (libtiff) before 3.8.2 might allow context-dependent attackers to execute arbitrary code via unknown vectors involving decoding large RLE images.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1137-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)squeeze, squeeze (security)3.9.4-5+squeeze10fixed
squeeze (lts)3.9.4-5+squeeze12fixed
wheezy, wheezy (security)4.0.2-6+deb7u3fixed
jessie4.0.3-12.3fixed
stretch, sid4.0.3-13fixed
tiff3 (PTS)wheezy3.9.6-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)3.8.2-6high
tiffsourcesarge3.7.2-7highDSA-1137-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (fixed prior to initial upload)

Search for package or bug name: Reporting problems