CVE-2006-3467

NameCVE-2006-3467
DescriptionInteger overflow in FreeType before 2.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PCF file, as demonstrated by the Red Hat bad1.pcf test file, due to a partial fix of CVE-2006-1861.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1178-1, DSA-1193-1
NVD severityhigh (attack range: remote)
Debian Bugs379920, 383353

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freetype (PTS)wheezy2.4.9-1.1+deb7u3fixed
wheezy (security)2.4.9-1.1+deb7u7fixed
jessie (security), jessie2.5.2-3+deb8u2fixed
stretch2.6.3-3.2fixed
buster2.8-0.2fixed
sid2.8.1-0.1fixed
libxfont (PTS)wheezy1:1.4.5-5fixed
wheezy (security)1:1.4.5-5+deb7u1fixed
jessie1:1.5.1-1fixed
jessie (security)1:1.5.1-1+deb8u1fixed
stretch1:2.0.1-3fixed
stretch (security)1:2.0.1-3+deb9u1fixed
buster, sid1:2.0.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freetypesource(unstable)2.2.1-5medium379920
freetypesourcesarge2.1.7-6highDSA-1178-1
libxfontsource(unstable)1:1.2.0-2medium383353
xfree86sourcesarge4.3.0.dfsg.1-14sarge2highDSA-1193-1

Search for package or bug name: Reporting problems