CVE-2006-3743

NameCVE-2006-3743
DescriptionMultiple buffer overflows in ImageMagick before 6.2.9 allow user-assisted attackers to execute arbitrary code via crafted XCF images.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1168-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs385062
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)squeeze1.3.12-1fixed
wheezy1.3.16-1.1fixed
stretch, jessie1.3.20-3+deb8u1fixed
sid1.3.21-3fixed
imagemagick (PTS)squeeze, squeeze (security)8:6.6.0.4-3+squeeze4fixed
squeeze (lts)8:6.6.0.4-3+squeeze6fixed
wheezy (security), wheezy8:6.7.7.10-5+deb7u3fixed
stretch, jessie8:6.8.9.9-5fixed
sid8:6.8.9.9-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.1.7-8medium
imagemagicksource(unstable)7:6.2.4.5.dfsg1-0.10medium385062
imagemagicksourcesarge6:6.0.6.2-2.7mediumDSA-1168-1

Search for package or bug name: Reporting problems