CVE-2006-3747

NameCVE-2006-3747
DescriptionOff-by-one error in the ldap scheme handling in the Rewrite module (mod_rewrite) in Apache 1.3 from 1.3.28, 2.0.46 and other versions before 2.0.59, and 2.2, when RewriteEngine is enabled, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted URLs that are not properly handled using certain rewrite rules.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1131-1, DSA-1132-1
NVD severityhigh (attack range: remote)
Debian Bugs380182, 380231

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)wheezy2.2.22-13+deb7u6fixed
wheezy (security)2.2.22-13+deb7u12fixed
jessie2.4.10-10+deb8u9fixed
jessie (security)2.4.10-10+deb8u11fixed
stretch (security), stretch2.4.25-3+deb9u3fixed
buster, sid2.4.27-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apachesource(unstable)1.3.34-3medium380231
apachesourcesarge1.3.33-6sarge2highDSA-1131-1
apache2source(unstable)2.0.55-4.1medium380182
apache2sourcesarge2.0.54-5sarge1highDSA-1132-1

Search for package or bug name: Reporting problems