CVE-2006-4112

NameCVE-2006-4112
DescriptionUnspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or "data loss," a different vulnerability than CVE-2006-4111.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs382255

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)jessie2:4.1.8-1+deb8u4fixed
jessie (security)2:4.1.8-1+deb8u5fixed
stretch2:4.2.7.1-1+deb9u1fixed
buster2:5.2.2.1+dfsg-1fixed
bullseye, sid2:5.2.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)1.1.6-1medium382255

Search for package or bug name: Reporting problems