CVE-2006-4144

NameCVE-2006-4144
DescriptionInteger overflow in the ReadSGIImage function in sgi.c in ImageMagick before 6.2.9 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via large (1) bytes_per_pixel, (2) columns, and (3) rows values, which trigger a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1213
NVD severitylow (attack range: remote, user-initiated)
Debian Bugs383314, 383333
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)squeeze1.3.12-1fixed
wheezy1.3.16-1.1fixed
stretch, sid, jessie1.3.20-3+deb8u1fixed
imagemagick (PTS)squeeze, squeeze (security)8:6.6.0.4-3+squeeze4fixed
squeeze (lts)8:6.6.0.4-3+squeeze6fixed
wheezy, wheezy (security)8:6.7.7.10-5+deb7u3fixed
stretch, sid, jessie8:6.8.9.9-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.1.7-7medium383333
imagemagicksource(unstable)7:6.2.4.5.dfsg1-0.10medium383314
imagemagicksourcesarge6:6.0.6.2-2.8lowDSA-1213

Search for package or bug name: Reporting problems