CVE-2006-4168

NameCVE-2006-4168
DescriptionInteger overflow in the exif_data_load_data_entry function in libexif/exif-data.c in Libexif before 0.6.16 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via an image with many EXIF components, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1310-1
NVD severitymedium
Debian Bugs430012

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libexif (PTS)stretch0.6.21-2+deb9u4fixed
stretch (security)0.6.21-2+deb9u5fixed
buster, buster (security)0.6.21-5.1+deb10u5fixed
bookworm, sid, bullseye0.6.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libexifsourcesarge0.6.9-6sarge1DSA-1310-1
libexifsourceetch0.6.13-5etch1DSA-1310-1
libexifsource(unstable)0.6.16-1430012

Search for package or bug name: Reporting problems