CVE-2006-4182

NameCVE-2006-4182
DescriptionInteger overflow in ClamAV 0.88.1 and 0.88.4, and other versions before 0.88.5, allows remote attackers to cause a denial of service (scanning service crash) and execute arbitrary code via a crafted Portable Executable (PE) file that leads to a heap-based buffer overflow when less memory is allocated than expected.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1196-1
NVD severityhigh (attack range: remote)
Debian Bugs393445
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)squeeze0.98.1+dfsg-1+deb6u3fixed
squeeze (lts)0.98.1+dfsg-1+deb6u4fixed
wheezy0.98.5+dfsg-0+deb7u2fixed
jessie, sid0.98.6+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.88.5-1high393445
clamavsourcesarge0.84-2.sarge.11highDSA-1196-1

Search for package or bug name: Reporting problems