CVE-2006-4338

NameCVE-2006-4338
Descriptionunlzh.c in the LHZ component in gzip 1.3.5 allows context-dependent attackers to cause a denial of service (infinite loop) via a crafted GZIP archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1181-1
Debian Bugs401301

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gzip (PTS)buster, buster (security)1.9-3+deb10u1fixed
bullseye (security), bullseye1.10-4+deb11u1fixed
sid, trixie, bookworm1.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gzipsourcesarge1.3.5-10sarge2DSA-1181-1
gzipsource(unstable)1.3.5-15medium
lhasource(unstable)1.14i-10.1medium401301

Notes

[sarge] - lha <no-dsa> (Non-free not supported)
[etch] - lha <no-dsa> (Non-free not supported)

Search for package or bug name: Reporting problems