CVE-2006-4535

NameCVE-2006-4535
DescriptionThe Linux kernel 2.6.17.10 and 2.6.17.11 and 2.6.18-rc5 allows local users to cause a denial of service (crash) via an SCTP socket with a certain SO_LINGER value, possibly related to the patch for CVE-2006-3745. NOTE: older kernel versions for specific Linux distributions are also affected, due to backporting of the CVE-2006-3745 patch.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1183-1, DSA-1184-2
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fai-kernelssourcesarge1.9.1sarge4mediumDSA-1184-2
kernel-source-2.4.27sourcesarge2.4.27-10sarge4mediumDSA-1183-1
kernel-source-2.6.8sourcesarge2.6.8-16sarge5mediumDSA-1184-2
linux-2.6source(unstable)2.6.18-1medium
systemimagersourcesarge3.2.3-6sarge3mediumDSA-1183-1

Search for package or bug name: Reporting problems