CVE-2006-4574

NameCVE-2006-4574
DescriptionOff-by-one error in the MIME Multipart dissector in Wireshark (formerly Ethereal) 0.10.1 through 0.99.3 allows remote attackers to cause a denial of service (crash) via certain vectors that tragger an assertion error related to unexpected length values.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severitymedium (attack range: remote)
Debian Bugs396258
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14fixed
squeeze (lts)1.2.11-6+squeeze15fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy14fixed
jessie, sid1.12.1+g01b65bf-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)0.99.4-1medium396258

Search for package or bug name: Reporting problems