CVE-2006-4790

NameCVE-2006-4790
Descriptionverify.c in GnuTLS before 1.4.4, when using an RSA key with exponent 3, does not properly handle excess data in the digestAlgorithm.parameters field when generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents GnuTLS from correctly verifying X.509 and other certificates that use PKCS, a variant of CVE-2006-4339.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1182-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot known to be vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls11source(unstable)(unfixed)high
gnutls11sourcesarge1.0.16-13.2sarge2mediumDSA-1182-1
gnutls12source(unstable)(unfixed)high
gnutls13source(unstable)1.4.4-1high

Notes

GNUTLS-SA-2006-4

Search for package or bug name: Reporting problems