CVE-2006-4810

NameCVE-2006-4810
DescriptionBuffer overflow in the readline function in util/texindex.c, as used by the (1) texi2dvi and (2) texindex commands, in texinfo 4.8 and earlier allows local users to execute arbitrary code via a crafted Texinfo file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1219
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
texinfo (PTS)squeeze4.13a.dfsg.1-6fixed
wheezy4.13a.dfsg.1-10fixed
jessie5.2.0.dfsg.1-6fixed
stretch, sid6.0.0.dfsg.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
texinfosource(unstable)4.8.dfsg.1-4medium
texinfosourcesarge4.7-2.2sarge2mediumDSA-1219

Search for package or bug name: Reporting problems