CVE-2006-4811

NameCVE-2006-4811
DescriptionInteger overflow in Qt 3.3 before 3.3.7, 4.1 before 4.1.5, and 4.2 before 4.2.1, as used in the KDE khtml library, kdelibs 3.1.3, and possibly other packages, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted pixmap image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1200-1
NVD severitymedium (attack range: remote)
Debian Bugs394192, 394313

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11fixed
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
buster, sid, stretch4:4.8.7+dfsg-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt-x11-freesource(unstable)3:3.3.7-1medium394192, 394313
qt-x11-freesourcesarge3:3.3.4-3sarge1mediumDSA-1200-1
qt4-x11source(unstable)4.2.1-1medium394192

Search for package or bug name: Reporting problems