CVE-2006-4980

NameCVE-2006-4980
DescriptionBuffer overflow in the repr function in Python 2.3 through 2.6 before ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-1197-1, DSA-1198-1
Debian Bugs391589, 393053
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.5 (PTS)squeeze2.5.5-11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.2source(unstable)(not affected)
python2.3source(unstable)2.3.5-16393053
python2.3sourcesarge2.3.5-3sarge2DSA-1198-1
python2.4source(unstable)2.4.3-9391589
python2.4sourcesarge2.4.1-2sarge1DSA-1197-1
python2.5source(unstable)2.5-1391589

Notes

- python2.2 <not-affected> (Compiled without UCS-4 support)

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)