CVE-2006-5051

NameCVE-2006-5051
DescriptionSignal handler race condition in OpenSSH before 4.4 allows remote attackers to cause a denial of service (crash), and possibly execute arbitrary code if GSSAPI authentication is enabled, via unspecified vectors that lead to a double-free.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesCVE-2008-4109, DSA-1189-1, DSA-1212, DSA-1638-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)squeeze, squeeze (security)1:5.5p1-6+squeeze5fixed
squeeze (lts)1:5.5p1-6+squeeze6fixed
wheezy1:6.0p1-4+deb7u2fixed
wheezy (security)1:6.0p1-4+deb7u1fixed
jessie1:6.7p1-5fixed
stretch, sid1:6.9p1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:4.6p1-1low
opensshsourceetch1:4.3p2-9etch3highDSA-1638-1
opensshsourcesarge1:3.8.1p1-8.sarge.6highDSA-1212
openssh-krb5source(unstable)(unfixed)high
openssh-krb5sourcesarge3.8.1p1-7sarge1highDSA-1189-1

Notes

From my analysis only openssh with Kerberos support should be vulnerable
However, we'll fix openssh as well just to make sure

Search for package or bug name: Reporting problems