CVE-2006-5214

NameCVE-2006-5214
DescriptionRace condition in the Xsession script, as used by X Display Manager (xdm) in NetBSD before 20060212, X.Org before 20060225, and Solaris 8 through 10 before 20061006, causes a user's Xsession errors file to have weak permissions before a chmod is performed, which allows local users to read Xsession errors files of other users.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xdm (PTS)bookworm, sid, buster, bullseye1:1.1.11-3fixed
xorg (PTS)buster1:7.7+19fixed
bullseye1:7.7+22fixed
bookworm, sid1:7.7+23fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xdmsource(unstable)1:1.0.5-1low
xorgsource(unstable)1:7.1.0-13low

Notes

[sarge] - xfree86 <no-dsa> (Minor issue)
probably fixed earlier than 1:1.0.5

Search for package or bug name: Reporting problems