CVE-2006-5791

NameCVE-2006-5791
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in elogd.c in ELOG 2.6.2 and earlier allow remote attackers to inject arbitrary HTML or web script via (1) the filename for downloading, which is not quoted in an error message by the send_file_direct function, and (2) the Type or Category values in a New entry, which is not properly handled in an error message by the submit_elog function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1242-1
NVD severitylow (attack range: remote)
Debian Bugs392016

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
elog (PTS)jessie2.9.2+2014.05.11git44800a7-2+deb8u1fixed
stretch3.1.2-1-1fixed
buster, sid3.1.3-1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
elogsource(unstable)2.6.2+r1754-1medium392016
elogsourcesarge2.5.7+r1558-4+sarge3lowDSA-1242-1

Search for package or bug name: Reporting problems