CVE-2006-5815

NameCVE-2006-5815
DescriptionStack-based buffer overflow in the sreplace function in ProFTPD 1.3.0 and earlier allows remote attackers, probably authenticated, to cause a denial of service and execute arbitrary code, as demonstrated by vd_proftpd.pm, a "ProFTPD remote exploit."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1222-1
NVD severityhigh (attack range: remote)
Debian Bugs399070

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)wheezy, wheezy (security)1.3.4a-5+deb7u3fixed
jessie1.3.5-1.1+deb8u2fixed
jessie (security)1.3.5-1.1+deb8u1fixed
stretch1.3.5b-4fixed
buster, sid1.3.5d-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpdsourcesarge1.2.10-15sarge3highDSA-1222-1
proftpd-dfsgsource(unstable)1.3.0-15high399070

Search for package or bug name: Reporting problems