CVE-2006-6144

NameCVE-2006-6144
DescriptionThe "mechglue" abstraction interface of the GSS-API library for Kerberos 5 1.5 through 1.5.1, as used in Kerberos administration daemon (kadmind) and other products that use this library, allows remote attackers to cause a denial of service (crash) via unspecified vectors that cause mechglue to free uninitialized pointers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1fixed
stretch (security)1.15-1+deb9u2fixed
buster1.17-3+deb10u1fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6fixed
bookworm, sid1.18.3-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)(not affected)

Notes

- krb5 <not-affected> (Only 1.5 onwards are vulnerable)

Search for package or bug name: Reporting problems