CVE-2006-6799

NameCVE-2006-6799
DescriptionSQL injection vulnerability in Cacti 0.8.6i and earlier, when register_argc_argv is enabled, allows remote attackers to execute arbitrary SQL commands via the (1) second or (2) third arguments to cmd.php. NOTE: this issue can be leveraged to execute arbitrary commands since the SQL query results are later used in the polling_items array and popen function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1250-1
NVD severityhigh (attack range: remote)
Debian Bugs404818
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)squeeze, squeeze (security)0.8.7g-1+squeeze3fixed
squeeze (lts)0.8.7g-1+squeeze8fixed
wheezy0.8.8a+dfsg-5+deb7u4fixed
wheezy (security)0.8.8a+dfsg-5+deb7u6fixed
jessie0.8.8b+dfsg-8fixed
jessie (security)0.8.8b+dfsg-8+deb8u2fixed
stretch0.8.8f+ds1-1fixed
sid0.8.8f+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)0.8.6i-3high404818
cactisourcesarge0.8.6c-7sarge4highDSA-1250-1

Search for package or bug name: Reporting problems