CVE-2006-7228

NameCVE-2006-7228
DescriptionInteger overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 might allow context-dependent attackers to execute arbitrary code via a regular expression that involves large (1) min, (2) max, or (3) duplength values that cause an incorrect length calculation and trigger a buffer overflow, a different vulnerability than CVE-2006-7227. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1570-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)wheezy1:8.30-5fixed
jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster, sid2:8.39-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kazehakasesource(unstable)0.5.2-1medium
kazehakasesourceetch0.4.2-1etch1mediumDSA-1570-1
pcre3source(unstable)6.2-1medium
pcre3sourcesarge4.5+7.4-1medium

Notes

http://www.pcre.org/changelog.txt states fixed in 6.2

Search for package or bug name: Reporting problems