CVE-2006-7230

NameCVE-2006-7230
DescriptionPerl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1570-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)wheezy1:8.30-5fixed
jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster2:8.39-4fixed
sid2:8.39-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kazehakasesource(unstable)0.5.2-1medium
kazehakasesourceetch0.4.2-1etch1mediumDSA-1570-1
pcre3source(unstable)7.0-1medium
pcre3sourceetch6.7+7.4-2medium
pcre3sourcesarge4.5+7.4-1medium

Search for package or bug name: Reporting problems