CVE-2007-0045

NameCVE-2007-0045
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in Adobe Acrobat Reader Plugin before 8.0.0, and possibly the plugin distributed with Adobe Reader 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2, for Mozilla Firefox, Microsoft Internet Explorer 6 SP1, Google Chrome, Opera 8.5.4 build 770, and Opera 9.10.8679 on Windows allow remote attackers to inject arbitrary JavaScript and conduct other attacks via a .pdf URL with a javascript: or res: URI with (1) FDF, (2) XML, and (3) XFDF AJAX parameters, or (4) an arbitrarily named name=URI anchor identifier, aka "Universal XSS (UXSS)."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1336-1
NVD severitymedium (attack range: remote, user-initiated)

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mozilla-firefoxsourcesarge1.0.4-2sarge17mediumDSA-1336-1

Notes

NOT-FOR-US: Adobe Acrobat Reader Plugin
a fix for this is also in iceweasle 2.0.0.2+dfsg-1 (MFSA-2007-02)
and icape 1.0.8-1

Search for package or bug name: Reporting problems