CVE-2007-0104

NameCVE-2007-0104
DescriptionThe Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs406852

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)stretch0.48.0-2+deb9u2fixed
stretch (security)0.48.0-2+deb9u3fixed
buster0.71.0-5fixed
bullseye, sid20.09.0-2fixed
swftools (PTS)stretch0.9.2+git20130725-4.1fixed
xpdf (PTS)stretch3.04-4fixed
bullseye, sid, buster3.04-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:3.5.5-3unimportant
kofficesource(unstable)(unfixed)unimportant
popplersource(unstable)0.4.5-5.1unimportant
swftoolssource(unstable)(not affected)
xpdfsource(unstable)3.02unimportant406852

Notes

- swftools <not-affected> (first version that entered the archive is based on xpdf 3.02)
hardly a security issue; if someone sends someone a crafted PDF file triggering
such an endless loop the user will simply abort kpdf and never look at
that file again, this is only denial of service by a _very_ far stretch
of imagination. I suppose KDE Security only issued an update for it
because the shared underlying code was part of the Month of Apple Bugs
and they wanted to debunk claims of code injection.

Search for package or bug name: Reporting problems