CVE-2007-0242

NameCVE-2007-0242
DescriptionThe UTF-8 decoder in codecs/qutfcodec.cpp in Qt 3.3.8 and 4.2.3 does not reject long UTF-8 sequences as required by the standard, which allows remote attackers to conduct cross-site scripting (XSS) and directory traversal attacks via long sequences that decode to dangerous metacharacters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1292-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11fixed
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
stretch, buster, sid4:4.8.7+dfsg-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt-x11-freesource(unstable)3:3.3.7-4medium
qt4-x11source(unstable)4.2.2-2medium
qt4-x11sourceetch4.2.1-2etch1mediumDSA-1292-1

Search for package or bug name: Reporting problems