CVE-2007-0909

NameCVE-2007-0909
DescriptionMultiple format string vulnerabilities in PHP before 5.2.1 might allow attackers to execute arbitrary code via format string specifiers to (1) all of the *print functions on 64-bit systems, and (2) the odbc_result_all function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1264-1
NVD severityhigh (attack range: remote)
Debian Bugs410561, 410995

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)6:4.4.4-9high
php4sourceetch6:4.4.4-8+etch1high
php4sourcesarge4:4.3.10-19highDSA-1264-1
php5source(unstable)5.2.0-9medium410561, 410995
php5sourceetch5.2.0-8+etch1high

Search for package or bug name: Reporting problems