CVE-2007-0956

NameCVE-2007-0956
DescriptionThe telnet daemon (telnetd) in MIT krb5 before 1.6.1 allows remote attackers to bypass authentication and gain system access via a username beginning with a '-' character, a similar issue to CVE-2007-0882.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1276-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie (security), jessie1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.4.4-8high
krb5sourceetch1.4.4-7etch1highDSA-1276-1
krb5sourcesarge1.3.6-2sarge4highDSA-1276-1

Search for package or bug name: Reporting problems