CVE-2007-0957

NameCVE-2007-0957
DescriptionStack-based buffer overflow in the krb5_klog_syslog function in the kadm5 library, as used by the Kerberos administration daemon (kadmind) and Key Distribution Center (KDC), in MIT krb5 before 1.6.1 allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via crafted arguments, possibly involving certain format string specifiers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1276-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)buster1.17-3+deb10u3fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6+deb11u1fixed
bookworm, sid1.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcesarge1.3.6-2sarge4DSA-1276-1
krb5sourceetch1.4.4-7etch1DSA-1276-1
krb5source(unstable)1.4.4-8high

Search for package or bug name: Reporting problems