CVE-2007-1253

NameCVE-2007-1253
DescriptionEval injection vulnerability in the (a) kmz_ImportWithMesh.py Script for Blender 0.1.9h, as used in (b) Blender before 2.43, allows user-assisted remote attackers to execute arbitrary Python code by importing a crafted (1) KML or (2) KMZ file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
blender (PTS)jessie2.72.b+dfsg0-3fixed
jessie (security)2.72.b+dfsg0-3+deb8u1fixed
stretch (security), stretch2.79.b+dfsg0-1~deb9u1fixed
buster2.79.b+dfsg0-7fixed
bullseye2.80+dfsg-3fixed
sid2.80+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
blendersource(unstable)2.42a-6medium
blendersourcesarge(not affected)

Notes

[sarge] - blender <not-affected> (bug was introduced in version 2.42)
http://lists.alioth.debian.org/pipermail/secure-testing-team/2007-March/001095.html

Search for package or bug name: Reporting problems