CVE-2007-1268

NameCVE-2007-1268
DescriptionMutt 1.5.13 and earlier does not properly use the --status-fd argument when invoking GnuPG, which prevents Mutt from visually distinguishing between signed and unsigned portions of OpenPGP messages with multiple components, which allows remote attackers to forge the contents of a message without detection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mutt (PTS)jessie1.5.23-3vulnerable
jessie (security)1.5.23-3+deb8u1vulnerable
stretch (security), stretch1.7.2-1+deb9u1vulnerable
buster, sid1.10.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muttsource(unstable)(unfixed)unimportant

Notes

this is a "feature request", since gnupg is fixed from CVE-2007-1263

Search for package or bug name: Reporting problems