CVE-2007-1507

NameCVE-2007-1507
DescriptionThe default configuration in OpenAFS 1.4.x before 1.4.4 and 1.5.x before 1.5.17 supports setuid programs within the local cell, which might allow attackers to gain privileges by spoofing a response to an AFS cache manager FetchStatus request, and setting setuid and root ownership for files in the cache.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1271-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)wheezy1.6.1-3+deb7u5fixed
wheezy (security)1.6.1-3+deb7u7fixed
jessie (security), jessie1.6.9-2+deb8u5fixed
stretch1.6.20-2fixed
buster, sid1.6.21-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.4.2-6medium
openafssourcesarge1.3.81-3sarge2highDSA-1271-1

Search for package or bug name: Reporting problems