CVE-2007-1521

NameCVE-2007-1521
DescriptionDouble free vulnerability in PHP before 4.4.7, and 5.x before 5.2.2, allows context-dependent attackers to execute arbitrary code by interrupting the session_regenerate_id function, as demonstrated by calling a userspace error handler or triggering a memory limit violation.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1282-1, DSA-1283-1, DTSA-39-1, DTSA-40-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.39-0+deb7u2fixed
stretch, jessie5.6.7+dfsg-1fixed
sid5.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)6:4.4.6-2medium
php4sourceetch6:4.4.4-8+etch2mediumDSA-1282-1
php4sourcelenny6:4.4.4-9+lenny1mediumDTSA-40-1
php4sourcesarge4:4.3.10-20mediumDSA-1282-1
php5source(unstable)5.2.0-11medium
php5sourceetch5.2.0-8+etch3mediumDSA-1283-1
php5sourcelenny5.2.0-10+lenny1mediumDTSA-39-1

Search for package or bug name: Reporting problems